Page text getting stuck at a certain color

We appreciate your feedback - please let us know how we can improve AllProWebTools.
Post Reply
Stephanieo2940
AllPro Provider
AllPro Provider
Posts: 76
meble kuchenne Mikołów Knurów Czechowice-Dziedzice
Joined: Wed Jun 01, 2016 1:49 pm
Website: www.coachclientconnection.com

Page text getting stuck at a certain color

Post by Stephanieo2940 »

Hello,

I'm designing a website for a client in APWT, using the Pivot theme, and the text on one page has gotten stuck on green. I can't change the color. I've tried refreshing the page and logging out and back in, but the lime green text won't budge.

I've also found that, when it's not insisting on being green, it insists that all copy-and-pasting will occur in the default tiny blue font, even if the font surrounding the text I'm pasting is in readably large black text. Even if I paste in the middle of an existing correctly-formatted word, the pasted text will still be tiny and blue.

How do I fix these bugs so I can make the text whatever color I want, and make the copy-and-pasted text take on the same formatting as the text surrounding it?

Thanks in advance.

Stephanie
User avatar
JohnB
Support Team
Support Team
Posts: 1022
Joined: Wed Nov 04, 2015 3:57 pm
Website: www.allprowebtools.com

Re: Page text getting stuck at a certain color

Post by JohnB »

Could you provide us with a link to the webpage, so we can see what you are referring to?
Stephanieo2940
AllPro Provider
AllPro Provider
Posts: 76
Joined: Wed Jun 01, 2016 1:49 pm
Website: www.coachclientconnection.com

Re: Page text getting stuck at a certain color

Post by Stephanieo2940 »

It's still a work in progress, but here it is: http://anthonybliberty.myallprowebtools.com/Truckers/

He just told me he'll want to use a different theme, but I'd like to get an idea of how to avoid or fix this in case it happens again.
User avatar
JohnB
Support Team
Support Team
Posts: 1022
Joined: Wed Nov 04, 2015 3:57 pm
Website: www.allprowebtools.com

Re: Page text getting stuck at a certain color

Post by JohnB »

I am not entirely sure what happened. If you look at the source code for that page you will see the text inside of several span tags, which is odd. This could be the result of changing the text color many times in the WYSIWYG editor, but the editor typically avoids stacking span tags like this.

I do not believe changing the theme is going to correct this.

I would suggest copying all of the text out of the webpage editor, into a plain text editor like notepad, to save the words but not the formatting. Then if you clear the webpage, and paste the plain text content into a blank editor, you can start adding the formatting back. Hopefully starting from a clean slate would be all you need to fix this!

Code: Select all

<span style="color: #000000; font-size: 30px;">
  <span style="color: #000000;">
    <span style="color: #000000;">
      <span style="color: #000000;">
        <span style="color: #ffffff;">
          <span style="color: #ffffff;">
            <span style="color: #000000;">
              <span style="color: #000000;">
                <span style="color: #339966;">
                  <span style="color: #ffffff;">
                    <span style="color: #00ff00;">
                      <strong>
                        <span style="font-family: Baskerville, serif;">Tired of being on the road all the time? Let’s see how you can make even more money, while spending more time with your family and friends!</span>
                      </strong>
                    </span>
                  </span>
                </span>
              </span>
            </span>
          </span>
        </span>
      </span>
    </span>
  </span>
</span>
Stephanieo2940
AllPro Provider
AllPro Provider
Posts: 76
Joined: Wed Jun 01, 2016 1:49 pm
Website: www.coachclientconnection.com

Re: Page text getting stuck at a certain color

Post by Stephanieo2940 »

Thanks, John. Transferring the page content to another document, deleting all the words on the page, turning the words black in the document into which I'd pasted them, then pasting them back into the WYSIWYG editor worked.
Post Reply