Issue with Image slider when used on Landing page

Need help? Please give a detailed explanation of your problem.
Post Reply
Trannum3487
AllPro Expert
AllPro Expert
Posts: 91
meble kuchenne Mikołów Knurów Czechowice-Dziedzice
Joined: Mon Apr 19, 2021 8:27 am
Website: www.socialreachagency.com

Issue with Image slider when used on Landing page

Post by Trannum3487 »

Greetings,

This problem was earlier arisen and solved for a user. However, for a different user, I am facing the same issue.

Install ID: 4349

Link to an earlier post with the same problem on Forum: viewtopic.php?f=1&t=4551&p=10317&hilit=slider#p10317

"
Today, I noticed the image slider work for the a page having Theme ON. However, it does not work for the page where Theme is off.

In my case, I am building a landing page hence do not want to enable "Theme" option for that page. When I use the Image slider on Landing page, it populated error on console.
Error : $(...).nivoSlider is not a function

In my whole research for the problem, I noticed the library files for the Nivo slider exists for both web page and Landing page. However, the jquery library file is embedded two times for Landing page.
May be that is causing the problem.

I tired to find out in template file, however it seems files is not embedded directly.
I think first embed is from
<?
HeadIncludes();
print $headadd;
?>

code which I found from "No theme Header" template. Another I noticed is directly after the <body> tag. I tried to find the second one, but I did not get any template for "no theme" option.

Kindly check and guide me to solve this problem.

Let me know if you require any other details.

"

Thanks
User avatar
Lyza326
Support Team
Support Team
Posts: 7
Joined: Tue Jan 26, 2021 11:57 am
Website: www.allprowebtools.com

Re: Issue with Image slider when used on Landing page

Post by Lyza326 »

Please provide the URL where you are experiencing this issue so we can take a look.
Trannum3487
AllPro Expert
AllPro Expert
Posts: 91
Joined: Mon Apr 19, 2021 8:27 am
Website: www.socialreachagency.com

Re: Issue with Image slider when used on Landing page

Post by Trannum3487 »

User avatar
Dave
Support Team
Support Team
Posts: 1028
Joined: Wed May 11, 2011 10:30 am
Website: www.allprowebtools.com
Contact:

Re: Issue with Image slider when used on Landing page

Post by Dave »

It appears that all of the required files are being loaded on the page you have provided.

The next step would be to create a new web page with the them on and see if you can successfully add the SAME slider to that page successfully. If you can do this, you can compare the view-source of both pages to determine the cause.

You can also turn the them off on the new page to see and view the source to compare with when the them is on to determine the cause of the issue.
Trannum3487
AllPro Expert
AllPro Expert
Posts: 91
Joined: Mon Apr 19, 2021 8:27 am
Website: www.socialreachagency.com

Re: Issue with Image slider when used on Landing page

Post by Trannum3487 »

Greetings,

Thanks for your response. I have already set up two pages one with Theme ON and another with Theme OFF respectively.

https://tickets.giantcountryextravaganz ... -web-page/
https://tickets.giantcountryextravaganz ... -page-a23/

You will notice the first webpage is showing Slider and another is not. The only difference between the settings of these pages is Theme.

I have compared the View Source of both pages and only noticed
<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>
Library file is duplicate for the No Theme Webpage. Rest everything seems fine.

Below is the link to my earlier Forum Post for the same issue and you sorted that by doing some changes in the back end. That trick you applied worked earlier however, I re-checked today and noticed the same problem came back for that client also Install ID: 3770.

viewtopic.php?f=1&t=4551&hilit=slider

Kindly check thoroughly and confirm as soon as possible.

Thank you.
User avatar
Dave
Support Team
Support Team
Posts: 1028
Joined: Wed May 11, 2011 10:30 am
Website: www.allprowebtools.com
Contact:

Re: Issue with Image slider when used on Landing page

Post by Dave »

jquery.min.js is no longer being included twice on the page.

Please test again and let us know the results.
Trannum3487
AllPro Expert
AllPro Expert
Posts: 91
Joined: Mon Apr 19, 2021 8:27 am
Website: www.socialreachagency.com

Re: Issue with Image slider when used on Landing page

Post by Trannum3487 »

The problem is solved. That worked :)
https://tickets.giantcountryextravaganz ... Bradenton/

Thank you.
Post Reply